Silver Cow Party

题目:

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2..  M+1: Line  i+1 describes road  i with three space-separated integers:  Ai, Bi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10


题意:给出你奶牛个数,以及不同牛棚之间的所花的时间(单向),问所有奶牛去x点开会再回来所花的最短时间

分析:我们用的dijkstra算法中的dis指的是某一点到其他所有点的距离,因此在这个题目中我们只需要运用两次该算法然后求出两次的和的最小值即可;

代码:

#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
const int INF = 0x3f3f3f3f;
int dis1[1005], dis2[1005];               
int cost[1005][1005];
bool vis[1005];                           
int N, X, M;
void dijkstra(int s, int dis[])          
{
for(int i = 0; i <= N; i++)
{
vis[i] = false;
dis[i] = INF;
}
dis[s] = 0;
for(int k=1;k<=N;k++)
{
int minn=INF,v;
for(int u = 1; u <= N; u++)     
{
if(!vis[u] && minn>dis[u])
{
    v = u;
    minn=dis[u];
}
}
vis[v] = true;
for(int j = 1; j <= N; j++)
{
dis[j] = min(dis[j], dis[v] + cost[v][j]);
}
}
}


int main()
{
int i, j, a, b, c;
while(scanf("%d%d%d", &N, &M, &X) != EOF)
{
for(i = 1; i <= N; i++)             
for(j = 1; j <= N; j++)
{
if(i == j)
cost[i][j] = 0;
else
cost[i][j] = INF;
}
for(i = 0; i < M; i++)
{
scanf("%d%d%d", &a, &b, &c);   
cost[a][b] = c;
}
dijkstra(X, dis1);                 
for(i = 1; i <= N; i++)            //此处只需矩阵转置即可
{
for(j = 1; j < i; j++)
{
int temp = cost[i][j];
cost[i][j] = cost[j][i];
cost[j][i] = temp;
}
}
dijkstra(X, dis2);                 
int maxx = -INF;
for(i = 1; i <= N; i++)           
{
if(i != X)
{
int temp = dis1[i] + dis2[i];
if(maxx < temp)
maxx = temp;
}
}
printf("%d\n", maxx);
}
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值