Harmonic Number

题目:

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

分析:

看到这个式子第一反应是用欧拉的一个函数,      =ln(n)+r+1/2*n;r为欧拉常数,当然这个是有一定误差的,i因此尽量在限制的范围内打表,大的数用公式;

代码:

#include<stdio.h>
#include<math.h>
using namespace std;
const double r=0.57721566490153286060651209;
const int maxn=2000000;
double p[maxn];
int t,n;
void solve()
{
    p[1]=1.0;
    for(int i=2;i<=maxn;i++)
        p[i]=p[i-1]+(1.0/i);
}
int main()
{
    solve();
    scanf("%d",&t);
    int casee=0;
    double ans;
    while(t--)
    {
        scanf("%d",&n);
        if(n<=maxn)
            ans=p[n];
        else
            ans=log(n)+r+(1.0)/(2*n);
        printf("Case %d: %.10lf\n", ++casee, ans);
    }
}
 

在网上又看到一种方法,或许是自己见识太少吧觉得这个方法是非常妙的;

也是打表,只不过是分段打表,每隔50个数就打一次表,这样每个数进来最多只用进行49次计算;

代码:

#include<stdio.h>
using namespace std;
const int maxn=2000000;
double p[maxn];
int t,n;
void solve()
{
    p[1]=1.0;
    double s=1.0;
    for(int i=2;i<=100000000;i++)
    {
        s=s+(1.0/i);
        if(i%50==0) p[i/50]=s;
    }
}
int main()
{
    solve();
    int casee=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int x=n/50;
        double s=p[x];
        for(int i=50*x+1;i<=n;i++)
            s+=(1.0/i);
        printf("Case %d: %.10lf\n", ++casee, s);
    }
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值