hdu More is better

More is better

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 327680/102400K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers. 

题意很简单,查找最大的集合中元素的个数,这题没什么内存限制,数组直接开到10000000。

代码:
#include<stdio.h>
int fa[10000005];
int num[10000005];
int find(int x)
{
    if(x!=fa[x])
        fa[x]=find(fa[x]);
      return fa[x];
}

void Union(int x,int y)
{
      x=find(x);
      y=find(y);
      if(x!=y)
     {
         if(x>y)
            fa[y]=x;
        else
            fa[x]=y;
     }
}
int main()
{
       int n,i,a,b,ans;
       while(scanf("%d",&n)!=EOF)
       {
           int max=-1;
            for(i=1;i<10000001;i++)
            {
                 fa[i]=i;
                 num[i]=0;
            }
            for(i=0;i<n;i++)
            {
                 scanf("%d%d",&a,&b);
                 Union(a,b);
            }
            for(i=1;i<10000001;i++)
            {
                  ans=find(i);
                  num[ans]++;
            }
            for(i=1;i<10000001;i++)
             {
                  if(max<num[i])
                    max=num[i];
            }
            printf("%d\n",max);
       }
       return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值