HDU 1789 Doing Homework again

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
   
   
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
   
   
0 3 5
 



从前往后估计会比较难,这道题简单的做法,是用贪心,从最后一天往前判断当天要做的题目(因为做题顺序无关,只考虑总收益最大)。从前往后判断,将会有多种可能性;而每一个最后一天,它只需要取当前期限内的最优解(最大值)。


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>


using namespace std;


int day[1005], scores[1005];

int main()
{
	int t, n;
	cin >> t;
	while (t--)
	{
		multimap<int, int> homework;
		cin >> n;
		for (int i = 0; i < n; i++)
			scanf_s("%d", &day[i]);
		for (int i = 0; i < n; i++)
			scanf_s("%d", &scores[i]);
		for (int i = 0; i < n; i++)
			homework.insert(pair<int, int>(day[i], scores[i]));
		for (int d = homework.rbegin()->first; d > 0; d--)
		{
			multimap<int, int>::iterator it, maxIt;
			int max = -1;
			for (it = homework.begin(); it != homework.end() && it->first < d; it++);
			if (it != homework.end())
			{
				for (; it != homework.end(); it++)
				{
					if (it->second > max)
					{
						max = it->second;
						maxIt = it;
					}
				}
				homework.erase(maxIt);
			}
		}
		int minus = 0;
		for (multimap<int, int>::iterator it = homework.begin(); it != homework.end(); it++)
		{
			minus += it->second;
		}
		cout << minus << endl;
	}
	

	return 0;
}




" I am a man of fortune,and I must seek my fortune."
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值