1012 The Best Rank (25分)

测试地址:

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are Mlines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

【题目大意】

现已知 n 个考生的 3 门分数,平均分可以按照这三门算出来。然后分别对这四个分数从高到低排序,这样对每个考生来说有4个排名;

k 个查询,对于每一个学生 id,输出当前 id 学生的最好的排名和它对应的分数,如果名次相同,按照A>C>M>E的顺序输出;

如果当前 id 不存在,输出N/A。

【思路】

  • 用结构体存储学生的 id、四门成绩、四门排名、最好的排名对应的科目下标
  • 排名并列应该是 1、1、3、4、5,而不不是1、1、2、3、4,否则会有一个测试点不过
  • 平均分是四舍五入的,所以需要按照 +0.5 后取整,保证是四舍五入的(听说不不四舍五入也能通过…)
  • 存储的时候就按照ACME的顺序存储可以简化程序逻辑~
  • 用 exist 数组保存当前 id 是否存在,这个 id 对应的 stu 结构体的下标是多少。用 i+1 可以保证为 0 的都是不存在的,可以直接输出N/A,其余不为0的保存的值是对应的结构体 index + 1 的值

【AC代码】

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1e5+7;
typedef struct{
	int id, best;
	int scord[4], rank[4];
}num;
num a[maxn];
int flag = -1;
int exist[1000000];
int cmp(num a, num b){
	return a.scord[flag] > b.scord[flag];
}
int main(){
	int n, m;
	cin >> n >> m;
	for(int i = 0; i < n; i++){
		cin >> a[i].id >> a[i].scord[1] >> a[i].scord[2] >> a[i].scord[3];
		a[i].scord[0] = (a[i].scord[1]+a[i].scord[2]+a[i].scord[3])/3.0 + 0.5;
	}
	for(flag = 0; flag <= 3; flag++){
		sort(a, a+n, cmp);
		a[0].rank[flag] = 1;
		for(int i = 1; i < n; i++){
			a[i].rank[flag] = i+1;
			if(a[i].scord[flag] == a[i-1].scord[flag]){
				a[i].rank[flag] = a[i-1].rank[flag];
			}
		}
	}
	for(int i = 0; i < n; i++){
		exist[a[i].id] = i+1;
		a[i].best = 0;
		int minn = a[i].rank[0];
		for(int j = 1; j <= 3; j++){
			if(minn > a[i].rank[j]){
				minn = a[i].rank[j];
				a[i].best = j;
			}
		}
	}
	char c[5] = {'A', 'C', 'M', 'E'};
	while(m--){
		int id;
		cin >> id;
		int temp = exist[id];
		if(temp){
			int best = a[temp-1].best;
			cout << a[temp-1].rank[best] << " " << c[best] << endl;
		}
		else{
			cout << "N/A\n";
		}
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值