ACM练习题——爬楼梯

Climbing_Stairs
Description

You are climbing a stair case. It takes n steps to reach to the top.
你在爬楼梯。它需要n步才能到达顶点。

Each time you can either climb 1 or 2 steps. In how many distinct ways can you climb to the top?

每次你可以爬1级或2级。有多少种不同的方法可以爬到顶端?

Input

NONE

Output

NONE

Sample Input 1

2
Sample Output 1

2
Sample Input 2

3
Sample Output 2

3
Hint

For EX1:

  1. 1 step + 1 step

  2. 2 steps

For EX2:

  1. 1 step + 1 step + 1 step

  2. 1 step + 2 steps

  3. 2 steps + 1 step

PS:1 <= n <= 45

其实这道题挺简单的,看一下你就懂了
思路:
从第三项开始,每一项都是前两项之和。

#include<stdio.h>
int main(void){
	int n,i,num;
	int a[200];
	a[0]=1;
	a[1]=2;
	for(i=2;i<200;i++){
		a[i]=a[i-2]+a[i-1];
	}
	while(scanf("%d",&n) != EOF){
		printf("%d\n",a[n-1]);
	}
	return 0;
}```

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值