hdu2102 A计划(双层BFS)

A计划

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13611    Accepted Submission(s): 3382


Problem Description
可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。
 

Input
输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小N*M(1 <= N,M <=10)。T如上所意。接下去的前N*M表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。
 

Output
如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。
 

Sample Input
  
  
1 5 5 14 S*#*. .#... ..... ****. ...#. ..*.P #.*.. ***.. ...*. *.#..
 

Sample Output
  
  
YES
 

Source
 

Recommend
xhd   |   We have carefully selected several similar problems for you:   1253  1180  1372  1728  2717 
 

Statistic |  Submit |  Discuss |  Note
我还是说几个注意点吧。

1.起点一定是(0,0,0)

2.如果#的对应位置是#或者* 无法移动

3.终点可以再任意一层

4.昨晚上睡觉时候想到的。如果在第二层中有#会移动到第一层。。我忽略了4, 以至于wa了几次

#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
char map[2][15][15];
int n,m,t;
int dir[4][2]={1,0,-1,0,0,1,0,-1};
int vis[2][15][15],flag;
struct node
{
	int k,x,y,cnt;
	friend bool operator<(node a,node b)
	{
		return a.cnt>b.cnt;
	}
};
bool yes(int k,int x,int y)
{
	if(k<0||k>=2||x<0||y<0||x>=n||y>=m||map[k][x][y]=='*')
	return false;
	if(vis[k][x][y])
	return false;
	return true;
}
void bfs()
{
	priority_queue<node>s;
	node temp,temp1;
	while(!s.empty())
	s.pop();
	temp.k=0,temp.x=0,temp.y=0,temp.cnt=0;
	s.push(temp);
	vis[0][0][0]=1;
	while(!s.empty())
	{
		temp1=temp=s.top();
		s.pop();
		if(map[temp.k][temp.x][temp.y]=='P')
		{
			flag=temp.cnt;
			break;
		}
		if(temp.cnt>t)
		break;
		for(int i=0;i<4;i++)
		{
			temp.x+=dir[i][0];
			temp.y+=dir[i][1];
			if(yes(temp.k,temp.x,temp.y))
			{
				vis[temp.k][temp.x][temp.y]=1;
				temp.cnt++;
				if(map[temp.k][temp.x][temp.y]=='#'&&temp.k==0&&(map[temp.k+1][temp.x][temp.y]=='#'||map[temp.k+1][temp.x][temp.y]=='*'))
				{
					temp=temp1;
					continue;
				}
				if(map[temp.k][temp.x][temp.y]=='#'&&temp.k==1&&(map[temp.k-1][temp.x][temp.y]=='#'||map[temp.k-1][temp.x][temp.y]=='*'))
				{
					temp=temp1;
					continue;
				} 
				if(map[temp.k][temp.x][temp.y]=='#'&&temp.k==0)
				{
					temp.k++;
					vis[temp.k][temp.x][temp.y]=1;
				}
				if(map[temp.k][temp.x][temp.y]=='#'&&temp.k==1)
				{
					temp.k--;
					vis[temp.k][temp.x][temp.y]=1;
				}
				s.push(temp);
			}
			temp=temp1;
		} 
	}
}
int main()
{
	int ncase;
	scanf("%d",&ncase);
	while(ncase--)
	{
		memset(map,0,sizeof(map));
		memset(vis,0,sizeof(vis));
		scanf("%d %d %d",&n,&m,&t);
		for(int k=0;k<2;k++)
		for(int i=0;i<n;i++)
		scanf("%s",map[k][i]);
		flag=0;
		bfs();
		if(flag&&flag<=t)
		printf("YES\n");
		else
		printf("NO\n");
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值