HDU2102(双层BFS)

A计划

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15488 Accepted Submission(s): 3867

Problem Description
可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。

Input
输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小N*M(1 <= N,M <=10)。T如上所意。接下去的前N*M表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。

Output
如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。

Sample Input
1
5 5 14
S*#*.
.#…
…..
**.
…#.

..*.P

.*..

*..
…*.
*.#..

Sample Output
YES

Source
HDU 2007-6 Programming Contest

#include "cstring"
#include "cstdio"
#include "string.h"
#include "iostream"
#include "queue"
using namespace std;
typedef struct node
{
    int x,y,floor;
    int step;
}node;
int n,m,lim;
int start[3];
int en[3];
char map[2][15][15];
int vis[2][15][15];
int go[4][2]={1,0,0,1,-1,0,0,-1};
bool check(node x)
{
    if(x.x<0||x.y<0||x.x>=n||x.y>=m)
        return true;
    if(map[x.floor][x.x][x.y]=='*')
        return true;
    return false;
}
void bfs()
{
    memset(vis,0,sizeof(vis));
    node now,next;
    queue <node>list;
    now.floor=start[0];
    now.x=start[1];
    now.y=start[2];
    now.step=0;
    vis[now.floor][now.x][now.y]=1;
    list.push(now);
    while(!list.empty())
    {
        now=list.front();
        list.pop();
        if(now.floor==en[0]&&now.x==en[1]&&now.y==en[2])
        {
            printf("YES\n");
            return;
        }
        if(now.step>=lim)
            break;
        for(int i=0;i<4;i++)
        {
            next=now;
            next.x+=go[i][0];
            next.y+=go[i][1];
            next.step++;
            if(check(next))
                continue;
            if(vis[next.floor][next.x][next.y]==1)
                continue;
            vis[next.floor][next.x][next.y]=1;
            if(map[next.floor][next.x][next.y]=='#')
            {
                next.floor=!next.floor;
                if(vis[next.floor][next.x][next.y])
                    continue;
                if(map[next.floor][next.x][next.y] == '*' || map[next.floor][next.x][next.y] == '#')
                    continue;
                 vis[next.floor][next.x][next.y]=1;
            }
            if(next.floor==en[0]&&next.x==en[1]&&next.y==en[2])
            {
                printf("YES\n");
                return;
            }
            list.push(next);
        }
    }
    printf("NO\n");
}




int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d%d%d",&n,&m,&lim);
        for(int k=0;k<2;k++)
        {
            for(int i=0;i<n;i++)
            {
                scanf("%s",map[k][i]);
                for(int j=0;j<m;j++)
                {
                    if(map[k][i][j]=='S')
                    {
                        start[0]=k;start[1]=i;start[2]=j;
                    }
                    if(map[k][i][j]=='P')
                    {
                        en[0]=k;en[1]=i;en[2]=j;
                    }
                }
            }
        }
        bfs();
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值