linux下使用yum upgrade软件包

今天本来准备zabbix,但是发现报错,报错很简单是缺少openssl,检查发现已经安装了,但是openssl版本太老了,系统装的是1.0.1,需要的1.0.2.

怎么升级呢?网上一般是采用的源码升级,如果你不需要升级到最新版本,那么也可以使用yum进行升级,好处就是他会升级其它所有的依赖包,而且不需要配置环境变量等信息.

当前我的操作系统是centos7.3,我还有一个环境是centos7.6,上面的openssl版本是1.0.2,那么就可以使用centos7.6的镜像文件直接进行升级

将centos7.6的镜像文件挂载的服务器上.

执行下面的:

yum clean all

yum makecache

yum upgrade openssl -y

这样就可以直接安装了

下面可以看到openssl已经更新:

[root@dsgmon ~]# rpm -qa |grep openssl
openssl-1.0.2k-16.el7.x86_64
openssl098e-0.9.8e-29.el7.centos.3.x86_64
openssl-devel-1.0.2k-16.el7.x86_64
openssl-libs-1.0.2k-16.el7.x86_64
 

 

 

©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页