数据结构实验之栈与队列二:一般算术表达式转换成后缀式

Problem Description

对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。

Input

输入一个算术表达式,以‘#’字符作为结束标志。

Output

输出该表达式转换所得到的后缀式。

Example Input
a*b+(c-d/e)*f#
Example Output
ab*cde/-f*+
Hint
Author
      
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
using namespace std;
typedef char selemtype;
typedef int status;
#define stackmax 10000
#define stacknum 10
#define true 1
#define error 0
typedef struct
{
    selemtype *base;
    selemtype *top;
    int stacksize;
} sqstack;
int initstack(sqstack &S)
{
    S.base=new selemtype[stackmax];
    S.top=S.base;
    S.stacksize=stackmax;
    return 1;
}
int push(sqstack &S, selemtype e)
{
    if(S.top-S.base>=stackmax)
    {
        S.base=(selemtype *)realloc(S.base,(S.stacksize+stacknum) * sizeof(selemtype));
        S.top=S.base+S.stacksize;
        S.stacksize+=stacknum;
    }
    *S.top++=e;
    return 1;
}
int pop(sqstack &S, selemtype &e)
{
    if(S.top==S.base)
        return 0;
    e=*--S.top;
    return 1;
}


status stackempty(sqstack &S)
{
    if(S.base==S.top)
        return true;
    else
        return false;
}
int compare(char a)
{
    if(a=='*'||a=='/')
        return 2;
    else if(a=='+'||a=='-')
        return 1;
    else if(a=='(')
        return 3;
    else if(a==')')
        return 4;
    return 0;
}
int main()
{
    sqstack S;
    initstack(S);
    selemtype e;
    char exp[1000];
    int i=0,a=0;
    char s[1000];
    while(~scanf("%c",&s[i])&&s[i]!='#')
    {
        if((s[i]>='a'&&s[i]<='z')||(s[i]>='A'&&s[i]<='Z'))
        {
            exp[a++]=s[i];
        }
        else
        {

            if(stackempty(S))
            {
                push(S,s[i]);

            }
            else if(compare(s[i])>compare(*(S.top-1)))
            {
                if(compare(s[i])==4)
                {
                    while(*(S.top-1)!='(')
                    {
                        exp[a++]=*(S.top-1);
                        pop(S,e);
                    }
                    pop(S,e);
                }
                else
                {
                    push(S,s[i]);
                }
            }
            else
            {
                if(*(S.top-1)!='(')
                {
                    exp[a++]=*(S.top-1);
                    pop(S,e);
                    push(S,s[i]);
                }
                else
                    push(S,s[i]);
            }
        }
        i++;
    }
    while((!stackempty(S)))
    {
        exp[a++]=*(S.top-1);
        pop(S,e);
    }
    for(i=0; i<strlen(exp); i++)
    {
        cout<<exp[i];
    }
    printf("\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值