Ducci 队列

22 篇文章 4 订阅
A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1, a2, · · · , an),the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers:(a1, a2, · · · , an) → (|a1 − a2|, |a2 − a3|, · · · , |an − a1|)Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuplesequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:(8, 11, 2, 7) → (3, 9, 5, 1) → (6, 4, 4, 2) → (2, 0, 2, 4) → (2, 2, 2, 2) → (0, 0, 0, 0).The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps:(4, 2, 0, 2, 0) → (2, 2, 2, 2, 4) → (0,0,0,2,2) → (0, 0, 2, 0, 2) → (0, 2, 2, 2, 2) → (2, 0, 0, 0, 2) →(2, 0, 0, 2, 0) → (2, 0, 2, 2, 2) → (2, 2, 0, 0, 0) → (0, 2, 0, 0, 2) → (2, 2, 0, 2, 2) → (0, 2, 2, 0, 0) →(2, 0, 2, 0, 0) → (2, 2, 2, 0, 2) → (0, 0, 2, 2, 0) → (0, 2, 0, 2, 0) → (2, 2, 2, 2, 0) → (0,0,0,2,2) → · · ·Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tupleor a periodic loop.InputYour program is to read the input from standard input. The input consists of T test cases. The numberof test cases T is given in the first line of the input. Each test case starts with a line containing aninteger n (3 ≤ n ≤ 15), which represents the size of a tuple in the Ducci sequences. In the followingline, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tupleor making a loop does not exceed 1,000.OutputYour program is to write to standard output. Print exactly one line for each test case. Print ‘LOOP’ ifthe Ducci sequence falls into a periodic loop, print ‘ZERO’ if the Ducci sequence reaches to a zeros tuple.Sample Input448 11 2 754 2 0 2 070 0 0 0 0 0 061 2 3 1 2 3Sample OutputZEROLOOPZEROLOOP

用队列存每此次的结果,用set判断是否只有0.
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<set>
using namespace std;
int main()
{
    queue<int>que;
    set<int>s2;
    set<int>::iterator ii;
    int n,m,i,j,t,k,s,s1;
    int f=0;
    scanf("%d",&n);
    while(n--)
    {
        f=0;
        scanf("%d",&m);
        for(i=0; i<m; i++)
        {
            scanf("%d",&t);
            que.push(t);
        }
        for(i=0; i<1000; i++)
        {
            for(j=0; j<m; j++)
            {
                if(j==0)
                {
                    t=que.front();
                    k=que.back();
                    if(t>k)
                        s=t-k;
                    else
                        s=k-t;
                }
                t=que.front();
                que.pop();
                if(j<m-1)
                {
                    k=que.front();
                    s1=t-k;

                    if(s1<0)
                    {
                        s1=-s1;
                    }
                    que.push(s1);
                    s2.insert(s1);
                }
                if(j==m-1)
                {
                    que.push(s);
                    s2.insert(s);
                }
            }
            if(s2.size()==1)
                {
                    f=1;
                    break;
                }
            s2.clear();
        }
        while(!que.empty())
        {
            que.pop();
        }
        if(f==0)
        {
            printf("LOOP\n");
        }
        else
        {
            printf("ZERO\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值