pat 1074 Reversing Linked List (25)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
using namespace std;

struct point
{
	char add[20], cnext[20];
	int data;
	int idx;
} num[100010];

bool cmp(const point &a1, const point &a2) {
	return a1.idx < a2.idx;
}

int main() {
	char add[20];
	int n, k;
	map<string, int> mapx;

	scanf("%s %d %d", add, &n, &k);

	for (int i = 0; i < n; ++i)
	{
		scanf("%s %d %s", num[i].add, &num[i].data, num[i].cnext);
		num[i].idx = 0x7fffffff;
		mapx.insert(make_pair(num[i].add, i));
	}

	int x = mapx.find(add)->second, i = 0;

	for(i = 0; i < n; ) {
		num[x].idx = i;
		i++;

		if(strcmp(num[x].cnext, "-1") == 0) break;

		x = mapx.find(num[x].cnext)->second;
	}

	sort(num, num+n, cmp);

	n = i;
	int high = n/k*k;

	for(i = 0; i+k <= high; i=i+k) {

		for(int j = k-1; j > 0; j--) {
			printf("%s %d %s\n", num[i+j].add, num[i+j].data, num[i+j-1].add);
		}

		printf("%s %d ", num[i].add, num[i].data);

		if(i+k==n) {
			printf("-1\n");
		} else if(i+2*k < n) {
			printf("%s\n", num[i+2*k-1].add);
		} else if(i+2*k > n) {
			printf("%s\n", num[i+k].add);
		}
	}	

	for(; i < n; i++) {
		printf("%s %d %s\n", num[i].add, num[i].data, num[i].cnext);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值