快速幂模板

#include<iostream>

#include<cstdio>
using namespace std;
int PowerMod(long long a, long long b, long long c)
{
    long long ans = 1;
    a=a%c;
    while(b>0)
    {
        if(b%2==1)
            ans=(ans*a)%c;
        b=b/2;
        a=(a*a)%c;
    }
    return ans;
}
int main()
{
    long long ans, a,b,m;
    while(cin>>a>>b>>m)
    {
        ans=quickmod(a,b,m);
        cout<<ans<<endl;
    }
    return 0;

}


幂两次取模

Description

计算2013^b^c mod 10000000

Input

两个整数 b>0 c>0<b,c<10000000)< body="">

Output

输出2013^b^c mod 10000000的结果

Sample Input

2012 2011

Sample Output

3307281
 
  
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int PowerMod(long long a, long long b, long long c)
{
    long long ans = 1;
    a=a%c;
    while(b>0)
    {
        if(b%2==1)
            ans=(ans*a)%c;
        b=b/2;
        a=(a*a)%c;
    }
    return ans;
}
int main()
{
    long long a,b,sum1,sum2;
    cin>>a>>b;
    sum1=PowerMod(2013,a,10000000);
    sum2=PowerMod(sum1,b,10000000);
    cout<<sum2<<endl;
    return 0;

}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值