PTA-03-树3 Tree Traversals Again

题目描述

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1


知识点:
已知先序遍历和中序遍历 求后序遍历

思路:
Push操作实际是先序遍历
出栈的顺序实际是中序遍历

二叉树的遍历(已知先中序求后序已经中后序求前序)

#include<iostream>
#include<ventor>
#include<stack>
using namespace std;

stack<int> S;
ventor<int> V1;//记录先序的序列
ventor<int> V2;//记录中序的序列
ventor<int> V3;//记录后序的序列
/*
分而治之
Root:先序找根
start end:中序找左右子树
*/
void Post(int Root,int start,int end)
{
    if(start>end) return;
    int i=start;
    while(i<end&&V1[Root]!=V2[i]) i++;
    Post(Root+1,start,i-1);
    Post(Root+1+i-start,i+1,end);
    V3.push_back(V2[i]);
}
int main()
{
    int N,n,temp;
    char Op[10];
    cin>>N;
    for(int i=0;i<N*2;i++){
        cin>>Op;
        if(Op[1]=='u'){
            cin>>n;
            S.push(n);
            V1.push_back(n);
        }else if(Op[1]=='o'){
            temp=S.top();
            S.pop();
            V2.push_back(temp);
        }
    }
    Post(0,0,N-1);
    for(int i=0;i<N;i++){
        if(i==0) cout<<V3[i];
        else cout<<" "<<V3[i];
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值