题目描述
This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).
Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.
Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.
Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.
Sample Input 1:
14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12
Sample Output 1:
Yes
Sample Input 2:
4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:
No
#include<cstdio>
#include<iostream>
#include<cmath>
#include<queue>
using namespace std;
#define MaxVertex 105
const double diameter=15.0;
struct Node{//存鳄鱼的信息
int hor;//x
int ver;//y
bool visit;//是否被访问
bool safe;//是否能上岸
bool jump;//是否一步跳上
};
bool isSafe;
int N;//点个数==鳄鱼数量
int D;//跳跃距离
struct Node G[MaxVertex];
//计算两点距离
double get_len(int x1,int y1,int x2,int y2)
{
return sqrt(pow(x1-x2,2.0)+pow(y1-y2,2.0));
}
//计算该点能否到达岸边
bool ashore(int x,int y)
{
if(abs(x-50)<=D||abs(y-50)<=D||abs(x+50)<=D||abs(y+50)<=D) return true;
else return false;
}
//确认该点是否能够上岸
void get_safe()
{
for(int i=0;i<N;i++){
if(ashore((G[i].hor),(G[i].ver))) G[i].safe=true;
else G[i].safe=false;
}
}
//在中心 确认哪些点可以一步跳上去
void get_jump()
{
for(int i=0;i<N;i++){
if(get_len(G[i].hor,G[i].ver,0,0)<=D+diameter/2) G[i].jump=true;
else G[i].jump=false;
}
}
//初始化
void Init()
{
cin>>N>>D;
int x,y;
for(int i=0;i<N;i++){
cin>>x>>y;
G[i].hor=x;
G[i].ver=y;
G[i].visit=false;
}
get_safe();
get_jump();
isSafe=false;
}
void bsf(int n)
{
queue<Node> q;
struct Node tmp;
G[n].visit=true;
q.push(G[n]);
while(!q.empty()){
tmp=q.front();
q.pop();
if(tmp.safe){
isSafe=true;
return;
}
for(int i=0;i<N;i++){
if(get_len(tmp.hor,tmp.ver,G[i].hor,G[i].ver)<=D&&!G[i].visit){
G[i].visit=true;
q.push(G[i]);
}
}
}
}
//遍历所有一步能跳到的鳄鱼
void listCompoent()
{
for(int i=0;i<N;i++){
if(G[i].jump){
bsf(i);
}
}
if(isSafe) cout<<"Yes"<<endl;
else cout<<"No"<<endl;
}
int main()
{
Init();
listCompoent();
return 0;
}