DP(最大子段和) 最大子矩阵 poj_1050

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11815    Accepted Submission(s): 5708


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 


题意: 在一个矩阵中找一个子矩阵,使其和最大。

思路:暴力从第 i 列到第 j 列的所有可能,把每一行的从第 i 到 j 列对应位置相加,生成一个一维和数列,然后使用最大子段和得到最大值。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>

using namespace std;

int a[105][105];
int b[105];
int c[105];
int n;

void init(int i, int j){

    for(int q = 1; q <= n; q++){
        b[q] = 0;
        for(int k = i; k <= j; k++)
            b[q] += a[q][k];
    }

}

int dp(){

    int themax = -999;
    for(int i = 1; i <= n; i++){
        if(c[i-1] > 0)themax = max(themax,c[i] = c[i-1]+b[i]);
        else themax = max(themax,c[i] = b[i]);
    }
    return themax;

}

int main(){

    while(scanf("%d",&n) != EOF){

        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));

        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                scanf("%d",&a[i][j]);

        int maxx = -9999;
        for(int i = 1; i <= n; i++)
        for(int j = i; j <= n; j++){
            init(i,j);
            maxx = max(maxx,dp());
        }

        cout << maxx << endl;
    }


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值