HDU_1003 MAX SUM

Max Sum                                              

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

题意:给你一个数组,让你求其中和最大的一个连续子序列。

思路:这就是一个最简单的最大子段和问题,具体见我的第一篇博文,里面讲了最大子段和的问题。

     这是链接:点击打开链接

贴一下代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
int a[100010];
int b[100010];
int c[100010];
int main(){
    int T,t;
    t= 1;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
            memset(a,0,sizeof(0));
            memset(b,0,sizeof(0));
            memset(c,0,sizeof(0));
        for(int i = 1; i <= n; i++)
            scanf("%d",&a[i]);
        for(int i = 1; i <= n; i++){
            if(b[i-1]>=0){
                b[i] = b[i-1]+a[i];
                c[i] = c[i-1]+1;
            }
            else{
                b[i] = a[i];
                c[i] = 1;
            }
        }

        int maxx = -999999;
        int jl;
        for(int i = 1; i <= n; i++)
            if(b[i] > maxx){
                maxx = b[i];
                jl = i;
            }
        printf("Case %d:\n",t++);
            printf("%d %d %d\n",maxx,jl-c[jl]+1,jl);
            if(T)printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值