hdu1069动态规划

                                               Monkey and Banana

                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                 Total Submission(s): 13022    Accepted Submission(s): 6854


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 
题意:给你某些种砖块,每种个数不限,给定长宽高,这个砖块可以六个面自由旋转,也就是说一个砖块可以有六个形态,如果一个砖块的某个形态的长和宽均小于另一个砖块的长和宽,我们就说这个砖块可以摞在另一个上面,现在问题来了,你最多能把这些砖块摞多高。
思路:类似于LCS的思路,数据比较水,最多就有180种形态,n*n完全可以搞定,如果数据过大的话就只能用平衡树优化了。现在我们将输入进来的n种砖块,每种都罗列出它的6种形态,然后将这6*n形态按照长由大到小排序,长相同的话就按宽由大到小排序。然后类似LCS的原理,用n*n的复杂度解决。状态转移方程: f[j]=max{f[i]}+v[j];其中,0<=i<=j,w[i]<w[j],h[i]<h[j]
贴一下代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;

struct K{
    int l;
    int w;
    int h;
}blocks[270];
int dp[500];
bool cmp(K a, K b){
    if(a.l != b.l)
        return a.l > b.l;
    else
        return a.w > b.w;
}
int main(){
    int n;
    int t = 1;
    while(scanf("%d",&n) && n){
        int number = 1;
        for(int i = 1; i <= n; i++){
            memset(dp,0,sizeof(dp));
            scanf("%d%d%d",&blocks[number].l,&blocks[number].w,&blocks[number].h);
            number++;
            blocks[number].l = blocks[number-1].w;
            blocks[number].w = blocks[number-1].l;
            blocks[number].h = blocks[number-1].h;
            number++;
            blocks[number].h = blocks[number-1].l;
            blocks[number].l = blocks[number-1].h;
            blocks[number].w = blocks[number-1].w;
            number++;
            blocks[number].l = blocks[number-1].w;
            blocks[number].w = blocks[number-1].l;
            blocks[number].h = blocks[number-1].h;
            number++;
            blocks[number].h = blocks[number-1].l;
            blocks[number].l = blocks[number-1].h;
            blocks[number].w = blocks[number-1].w;
            number++;
            blocks[number].l = blocks[number-1].w;
            blocks[number].w = blocks[number-1].l;
            blocks[number].h = blocks[number-1].h;
            number++;
        }
        sort(blocks+1,blocks+6*n+1,cmp);
        for(int i = 1; i <= 6*n; i++){
            int maxx = 0;
            for(int j = i-1; j >= 0; j--){
                if(blocks[i].l < blocks[j].l && blocks[i].w < blocks[j].w)
                    maxx = max(maxx,dp[j]);
            }
            dp[i] = maxx + blocks[i].h;
        }
        int themax = 0;
        for(int i = 1; i <= 6*n; i++)
            themax = max(themax,dp[i]);
            printf("Case %d: maximum height = ",t++);
        cout << themax << endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值