POJ 3278 Catch That Cow

ime Limit: 2000MS Memory Limit: 65536K
Total Submissions: 45496 Accepted: 14254

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source



比较水。
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
int dx[2]={1,-1};
int n,k;
int vis[100010];
typedef struct {
int x;
int step;             
}node;
node tmp;
queue<node> q;
int  bfs()
{
   int x,xx,t;    
     while(!q.empty())
     {
     tmp=q.front();
     q.pop();
     x=tmp.x;
     t=tmp.step;
     vis[x]=1;
        for(int i=0;i<3;i++)
        {   
           if(i==0)
              { xx=x+1;}
           if(i==1)
              {xx=x-1;}
           if(i==2)
              { xx=x+x; }           
 if(xx>=0&&xx<=100000&&vis[xx]==0)
    {     tmp.step=t+1;
          if(xx==k)
           return tmp.step;            
       else 
              {
              tmp.x=xx;
              vis[xx]=1;
              q.push(tmp);              
              }
     }
        }
       
}                                                           
 return 0;    
}



int main()
{
 int ans;
 while(cin>>n>>k) 
  {
  memset(vis,0,sizeof(vis));
  while(!q.empty())
  q.pop();
  ans=0;
  tmp.x=n;
    tmp.step=0;
    if(n>=k)
    {cout<<n-k<<endl;}
  else 
    {
      q.push(tmp);
      ans=bfs();
      cout<<ans<<endl;
    }
} 
    return 0;
    }




由一个初始的节点,向外扩散,用循环的方式一直将符合条件的节点入队列,出队列,直到找到最终要的节点,然后就
直接返回。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值