hdu1563

Find your present!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2740    Accepted Submission(s): 1813


Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
  
  
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
  
  
3 2
 
//AC: 
/*#include<stdio.h>
#include<string.h>
int num[1000000]={0}; 
int main()
{
	int n,i;
	int a[201];
	while(scanf("%d",&n)!=EOF&&n)
	{
		memset(num,0,sizeof(num));
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			num[a[i]]++;
		}
		for(i=1;i<=n;i++)
		{
			if(num[a[i]]==1) 
			printf("%d\n",a[i]);
		}
	}
	return 0;
}*/


//AC:
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int n,i,a[201];
	while(scanf("%d",&n)!=EOF&&n)
	{
		for(i=0;i<n;i++)
		scanf("%d",&a[i]);
		sort(a,a+n);//sort()默认从小到大排序 
		if(a[0]<a[1])
		printf("%d\n",a[0]);
		else if(a[n-1]>a[n-2])
		printf("%d\n",a[n-1]);
		else
		for(i=2;i<n-1;i++)
		if(a[i]>a[i-1]&&a[i]<a[i+1])
		printf("%d\n",a[i]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值