HDU 1563 Find your present!【暴力】

/*
解题思路:主要是求解给你一组数,叫你求出里面只出现一次的数字,数组比较小,可以逐个检验
解题人:lingnichong
解题时间:2014-09-02 10:29:37
解题体会:暴力求解
*/



Find your present!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2717    Accepted Submission(s): 1798


Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
  
  
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
  
  
3 2
 

Author
8600
 

Source
 

#include<stdio.h>
int arr[210];
int main()
{
    int n;
    int i,j;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;i++)
        	scanf("%d",&arr[i]);
    	for(i=0;i<n;i++)
    	{
    	    for(j=0;j<n;j++)
    	    {
    	        if(j==i)	continue;
    	        if(arr[i]==arr[j])	break;
    	    }
         	if(j==n)  break;    
    	}
     	printf("%d\n",arr[i]);
    }    
    
    return 0;
}     


这种解法感觉挺好的,就是不会用异或

#include <stdio.h>

int main()
{
    int t,s,m;
    while(scanf("%d",&t),t)
    {
         m=0;
        while(t--)
<span style="white-space:pre">	</span>{
        <span style="white-space:pre">	</span>scanf("%d",&s);
        <span style="white-space:pre">	</span>m^=s;
        }
        printf("%d\n",m);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值