hdu1051Wooden Sticks(贪心)

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12969    Accepted Submission(s): 5339


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 

Source



题目大意是:有一些木棒,木棒的长度和重量是已知的,,用一台机器处理这些木棒,机器一开始启动需要一个单位的时间,如果第i+1根木棒的长度和重量都不大于第i根木棒的长度和重量,那么处理时不需要消耗时间,否则需要消耗一个单位的时间。
思路:这事一道贪心题目,将木棒按照长度按照从小到大的的顺序排序,如果长度相等,按照重量从小到大的顺序排序。然后从小到大开始寻找,如果后面一根木棒的重量大于等于前一根木棒的重量,就将其标记为0,知道找到一根重量小的。
此题注意,处理第一根木棒是不需要消耗时间的,应为第一根木棒之前没有木棒,所以
相当于第一根木棒之前的木棒长度和重量都是0


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std; 
struct stick
{
	int len;
	int weight;
}node[5001];
int cmp(stick a,stick b)
{
	if(a.len!=b.len)
	return a.len<b.len;//按照长度从小到大排序 
	else return a.weight<b.weight;//长度一样按重量从小到大排序 
}
int main()
{
	int T,n,i,j;
	int temp,sum;
	scanf("%d",&T);
	while(T--)
	{
		sum=0;
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&node[i].len,&node[i].weight);
		}
		sort(node,node+n,cmp);
		for(i=0;i<n;i++)
		{
			if(node[i].weight!=0)
			{
				sum++;//一开始机器启动时间加1 
				temp=node[i].weight;
				for(j=i+1;j<n;j++)
				{
					if(node[j].weight>=temp)//由于长度是按照从小到大排好序的,所以只要比较重量就行了 
					{
						temp=node[j].weight;//如果打i+1根木棒的重量大于等于第i根木棒的重量,就将其标记为0,继续比较 
						node[j].weight=0;
					}
				}
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值