nyoj853 how many hairstyles can they see?(栈)

how many hairstyles can they see?

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

For example:

There are six cows, heights are 10  2  7  3  12  2.

Now Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

输入
Line 1: The number of cows, N. 
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
输出
Line 1: A single integer that is the sum of c1 through cN.
样例输入
6
10  2  7  3  12  2
样例输出
5
 
    
 
    
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=8e4+5;
int pos[maxn];
int stack[maxn];
int main()
{
	int n;
	int cow;
	while(scanf("%d",&n)!=EOF)
	{
		int top=0;
		scanf("%d",&cow);
		stack[++top]=cow;
		pos[top]=1;
		int ans=0;
		for(int i=2;i<=n;i++)
		{
			scanf("%d",&cow);
			while(top>0&&stack[top]<=cow)
			{
				ans+=i-pos[top]-1;
				top--;
			}
			stack[++top]=cow;
			pos[top]=i;
		}
		top--;
		while(top>0)
		{
			ans+=n-pos[top];
			top--;
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值