hdu 1035 Robot Motion

 
直接模拟走就行了。。。但是搞了好长。。。只考虑i=0,j=0.。没有考虑从那半边出去。。思考不严谨啊
 
 
Problem Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
 

Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
 

Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
 

Sample Input
  
  
3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0
 

Sample Output
  
  
10 step(s) to exit 3 step(s) before a loop of 8 step(s)
 
#include <iostream>
using namespace std;
char b;
      char a[13][13];
    int c[13][13];
int main()
{
 int x,y,k,i,j,t,m;
 while(cin>>x>>y,x||y)
 {
  cin>>k;
    for(i=0;i<=x+1;i++)
     for(j=0;j<=y+1;j++)
     {
      c[i][j]=0;
              if(i==0||j==0||i==x+1||j==y+1)  //边界初始化为1
      a[i][j]=0;
     else
      cin>>a[i][j];
     }
     i=1;
     j=k;
     b=a[i][j];
     m=0,t=1;
     while(1)
     {
      if(c[i][j]!=t)     //判断是否是已经走过的
      {
    c[i][j]=1;         //走过的进行标记
               if(b=='N')     
       i--;
      else if(b=='S')
       i++;    
      else if(b=='W')
       j--;
               else
       j++;
                b=a[i][j];      //将下一个的方向传给b 
      }
      else               //如果是走到已经走过的,说明有循环,
      {                  //那么从头开始走,走到有循环处
                   a[i][j]=0;
       i=1;
             j=k;
             b=a[i][j];
       t=m;
       m=-1;
      }
      m++;
      if(b==0)        //结束条件
       break; 
     }
     if(t==1)
     cout<<m<<" step(s) to exit"<<endl;
     else
      cout<<m<<" step(s) before a loop of "<<t-m<<" step(s)"<<endl;
 }
}
 
 
...这种找到有循环的时候直接就结束了。。开始想复杂了。
#include <iostream>using namespace std;char b; char a[13][13]; int c[13][13];int main(){ int x,y,k,i,j,t,m; while(cin>>x>>y,x||y) { cin>>k; for(i=0;i<=x+1;i++) for(j=0;j<=y+1;j++) { c[i][j]=0; if(i==0||j==0||i==x+1||j==y+1) //边界初始化为1 a[i][j]=0; else cin>>a[i][j]; } i=1; j=k; b=a[i][j]; m=0,t=1; while(1) { c[i][j]=++m; //走过的进行标记 a[i][j]='o'; if(b=='N') i--; else if(b=='S') i++; else if(b=='W') j--; else j++; b=a[i][j]; //将下一个的方向传给b if(b==0||a[i][j]=='o') //结束条件 break; } if(a[i][j]!='o') cout<<m<<" step(s) to exit"<<endl; else cout<<c[i][j]-1<<" step(s) before a loop of "<<m+1-c[i][j]<<" step(s)"<<endl; }
http://acm.hdu.edu.cn/showproblem.php?pid=1035
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值