hdu 1034 Candy Sharing Game

 

http://acm.hdu.edu.cn/showproblem.php?pid=1034

Problem Description

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6

36

2

2

2

2

2

11

22

20

18

16

14

12

10

8

6

4

2

4

2

4

6

8

0

Sample Output

15 14

17 22

4 8

Hint

The game ends in a finite number of steps because:

1. The maximum candy count can never increase.

2. The minimum candy count can never decrease.

3. No one with more than the minimum amount will ever decrease to the minimum.

4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

     题目说的是一个分糖果的游戏,n个学生围成一圈,每个人手上有a[i]个糖果,每一轮游戏开始时,学生手中的糖果都是偶数,他们都把自己手中一半的糖果分给他右边的同学。分完后手中糖果数是奇数的,老师会给他一颗糖果。如果所有人手中的糖果数都一样 游戏结束。

    输出总共进行了多少轮游戏 还有最后学生手中的糖果数。

 

 

开始题目理解错误,认为这个学生的糖果应该是前一个同学给他的加上自己的,然后再分给下一个同学,结果一直不对。。。后来发现是让先给下一个同学才能拿上一个同学了。。。。

 

#include <iostream>
using namespace std;
int f(int a[],int n)     //判断是否分配结束
{
    int i;
    for(i=0;i<n-1;i++)
        if(a[i]!=a[i+1])
            return 1;
    return 0;
}
int main()
{
    int n;
    
    while(cin>>n&&n)
    {
        int a[500],i,x=0,y;
        for(i=0;i<n;i++)
            cin>>a[i];
        while(f(a,n))
        {
            x++;
            y=a[n-1]/2;
            for(i=n-1;i>0;i--)
            {            
                a[i]=a[i]/2+a[i-1]/2;
                if(a[i]%2)
                    a[i]++;
            }
            a[0]=a[0]/2+y;
            if(a[0]%2)
                a[0]++;
        }
        cout<<x<<" "<<a[0]<<endl;
    }
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值