hdu Easier Done Than Said?

 http://acm.hdu.edu.cn/showproblem.php?pid=1039

发现自己真的不够细心。。整个写下来好多错误。。调试了半天。。。。思维啊,严谨啊


 

Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
 


 

Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.
 


 

Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.
 


 

Sample Input
  
  
a tv ptoui bontres zoggax wiinq eep houctuh end
 


 

Sample Output
  
  
<a> is acceptable. <tv> is not acceptable. <ptoui> is not acceptable. <bontres> is not acceptable. <zoggax> is not acceptable. <wiinq> is not acceptable. <eep> is acceptable. <houctuh> is acceptable.

 

#include <iostream>
#include <string.h>
using namespace std;
int main()
{
 char pass[100],end[4]={"end"},a[6]={'a','e','i','o','u'};
 while(cin>>pass)
 { int t,k1,k2,i,j,k,n,b=0;
  if(strcmp(pass,end)==0)
   break;
  cout<<"<"<<pass<<"> is";
        n=strlen(pass); 
  t=0;  
  for(i=0;i<n&&b!=-1;i++)
  {
    
     if(pass[i]!='e'&&pass[i]!='o')  //因为ee oo 除外
      if(pass[i]==pass[i+1])       //条件三:不能连续两个一样
                      b=-1;
    if(b!=-1)
    {
     k1=0;k2=0;                    //条件二:
       for(k=i;k<i+3&&k<n;k++)           //不能连续三个是元音或者三个辅音
                {                                 //其实除了第一次,后边的每次只是多加一个。可以优化
     b=k1;
     for(j=0;j<5;j++)
     if(pass[k]==a[j])
     {
      k1++;
      t=1;                     //条件一:含有元音
     }
     if(k1==b)
      k2++;
    }
     if(k1>2||k2>2)
      b=-1;
    }
  }
 
  if(b==-1||t==0)
   cout<<" not acceptable."<<endl;
  else
   cout<<" acceptable."<<endl;
   
 }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值