POJ1258 Agri-Net(Prim求解最小生成树)



Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
题目大意:给出一个邻接矩阵,矩阵的每个数字的grid[i][j]表示i号点和j号点之间有一条长度为grid[i][j]的边,现在用一些线把这些点连起来,求连起来的最小代价是多少。
赤裸裸的求最小生成树。现用Prim算法求解。Prim算法先将1号点装入树中,再求其他点到这棵树的最短距离,再把距离最小的点加进树中,同时再次更新所有点到这棵树的距离,注意这里只需要把所有点和之前加入的这个点进行比较就行了,因为前面的点最小距离都已经计算过最小值了。
#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

int main()
{
    int min0,n,i,j,grid[200][200],ans,a[200],minnum,cnt;//a[i]数组表示i号点到树的最短距离
    while(scanf("%d",&n)!=EOF)
    {
        ans=0;
        memset(grid,0,sizeof(grid));
        for (i=0;i<=n-1;i++)
        {
            for (j=0;j<=n-1;j++)
            {
                scanf("%d",&grid[i][j]);
            }
        }
        for (i=0;i<=n-1;i++)
        {
            a[i]=grid[i][0];
        }
        cnt=0;
        while(cnt<n-1)
        {
            min0=100000000;
            for (i=0;i<=n-1;i++)//找最短点
            {
                if (a[i]<min0&&a[i]!=0)
                {
                    minnum=i;
                    min0=a[i];
                }
            }
            ans=ans+a[minnum];
            a[minnum]=0;//置0表示此点已入树
            cnt++;
            for (i=0;i<=n-1;i++)//更新最短距离
            {
                if (grid[i][minnum]<a[i]&&grid[i][minnum]!=0&&a[i]!=0)
                {
                    a[i]=grid[i][minnum];
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值