hdu1031Design T-Shirt(水题)

Design T-Shirt

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12562    Accepted Submission(s): 5963


http://acm.hdu.edu.cn/showproblem.php?pid=1031

Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

 

 

Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.

 

 

Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

 

 

Sample Input

3 6 4

2 2.5 5 1 3 4

5 1 3.5 2 2 2

1 1 1 1 1 10

3 3 2

1 2 3

2 3 1

3 1 2

 

 

Sample Output

6 5 3 1

2 1

代码:

#include<iostream>
#include<cstring>
#include<cmath>
#include<iomanip>
#include<algorithm>
#include<cstdio>
#define inf 0x3f3f3f3f
using namespace std;

struct node
{
    long double num;
    int id;
}s[100005];

int cmp(node a,node b)
{
    return a.num>b.num;
}

int main()
{
    int n,m,k;
    while(cin>>n>>m>>k)
    {
        memset(s,0,sizeof(s));
        double l;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                cin>>l;
                s[j].num+=l;
                s[j].id=j+1;
            }
        }
        sort(s,s+m,cmp);
        //for(int i=0;i<m;i++)
            //cout<<s[i].num<<" "<<s[i].id<<endl;
        int a[100005];
        int h=0;
        for(int i=0;i<k;i++)
        {
            //cout<<s[i].num<<endl;
            a[h++]=s[i].id;
        }
        //for(int i=0;i<h;i++)
            //cout<<a[i]<<endl;
        sort(a,a+h);
        cout<<a[h-1];
        for(int i=h-2;i>=0;i--)
            cout<<" "<<a[i];
        cout<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值