hdu1020Encoding(水题)

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54227    Accepted Submission(s): 24112

http://acm.hdu.edu.cn/showproblem.php?pid=1020
 

Problem Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

 

 

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

 

 

Output

For each test case, output the encoded string in a line.

 

 

Sample Input

 

2 ABC ABBCCC

 

 

Sample Output

 

ABC A2B3C

代码:

#include<iostream>
#include<cstring>
#include<cmath>
#include<iomanip>
#include<algorithm>
#include<cstdio>
#define inf 0x3f3f3f3f
using namespace std;

int main()
{
    int n;
    char s[10005];
    cin>>n;
    while(n--)
    {
        cin>>s;
        int n=strlen(s);
        int h=1;
        for(int i=1;i<=n;i++)
        {
            if(s[i]==s[i-1])
            {
                h++;
            }
            else
            {
                if(h==1)
                    cout<<s[i-1];
                else if(h>1)
                    cout<<h<<s[i-1];
                h=1;
            }
        }
        cout<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值