HDU 1072 Nightmare【BFS】

1 篇文章 0 订阅

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7958    Accepted Submission(s): 3820


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
  
  
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
  
  
4 -1 13
 
本题由于点可以重复走,会导致超时,需要记录上次经过此点时还剩下的步数,如果下次再遇到,剩余步数比上一次多,则加入队列中,即可。

还有一点就是,关于爆炸的时间,并不一定每个点的爆炸时间一样,所以需要有多个爆炸时间,也就是说每个点配一个爆炸时间了,像下面我用的是target记录。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
#define maxn 10
int n,m,t;
int tab[maxn][maxn];
int vis[maxn][maxn]; //记录i,j点剩下的步数
struct Node{
	int x;
	int y;
	int step;
	int target;
};
queue<Node> q;
int dir[4][2] = {1,0,-1,0,0,1,0,-1};
int dead;
int sx,sy,cnt;
bool flag;
void findStart(){
	for(int i = 0; i < n; i++){
		for(int j = 0; j < m; j++){
			if(tab[i][j] == 2){
				sx= i;
				sy = j;
				return ;
			}
		}
	}
}
void bfs();
bool check(int x,int y);
int main(){
	scanf("%d",&t);
	while(t--){
		dead = 6;
		scanf("%d%d",&n,&m);
		for(int i = 0; i < n; i++){
			for(int j = 0; j < m; j++){
				scanf("%d",&tab[i][j]);
			}
		}
		findStart();
		flag = false;
		cnt = 0;
		memset(vis,0,sizeof(vis));
		bfs();
		if(!flag){
			printf("-1\n");
		}
	}
	return 0;
}
void bfs(){
	while(!q.empty()){
		q.pop();
	}
	Node node;
	node.x = sx;
	node.y = sy;
	node.step = 0;
	node.target = 6;
	vis[node.x][node.y] = 6;
	q.push(node);
	while(!q.empty()){
		node = q.front();
		q.pop();
		if(node.step >= node.target){
			continue;
		}
		if(tab[node.x][node.y] == 3){
			flag = true;
			printf("%d\n",node.step);
			break;
		}else if(tab[node.x][node.y] == 4){
			node.target = node.step + 6;
		}
		for(int i = 0; i < 4; i++){
			int tmpx = node.x + dir[i][0];
			int tmpy = node.y + dir[i][1];
			if(check(tmpx,tmpy)){
				if(vis[tmpx][tmpy] != 0){
					if(vis[tmpx][tmpy] >= (node.target - node.step - 1)){
						continue;
					}
				}
				Node no;
				no.x = tmpx;
				no.y = tmpy;
				no.step = node.step + 1;
				no.target = node.target;
				vis[no.x][no.y] = no.target - no.step;
				q.push(no);
			} 
		}
	}
}
bool check(int x,int y){
	if(x < 0 || x >= n || y < 0 || y >= m || tab[x][y] == 0 ){
		return false;
	}
	return true;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值