UVA之11300 - Spreading the Wealth

22 篇文章 7 订阅

 F. Spreading the Wealth 

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

【题意】


【解析】



【代码】

/*********************************
*   日期:2013-11-22
*   作者:SJF0115
*   题号: 题目11300 - Spreading the Wealth
*   来源:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=25&page=show_problem&problem=2275
*   结果:AC
*   来源:UVA
*   总结:
**********************************/
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

#define N 1000000 + 10

long long Money[N],C[N],total,M,FirstMoney,ans;

int main() {
    int i,n;
    while(scanf("%d",&n) != EOF){
        total = 0;
        //每人分得的金币
        for(i = 0;i < n;i++){
            scanf("%lld",&Money[i]);
            //总金额
            total+= Money[i];
        }
        //均摊后的金币
        M = total / n;
        C[0] = 0;
        for(i = 1;i < n;i++){
            C[i] = C[i-1] + Money[i-1] - M;
        }
        //排序
        sort(C,C+n);
        //取中位数
        FirstMoney = C[n/2];
        ans = 0;
        //计算转移的金币总额
        for(i = 0;i < n;i++){
            ans += abs(FirstMoney - C[i]);
        }
        printf("%lld\n",ans);
    }//while
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

@SmartSi

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值