记一个式子-HDU1013 Digital Roots

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 82803    Accepted Submission(s): 25934


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
   
   
24 39 0
 

Sample Output
   
   
6 3


题目大意:
这个题的要求是输入一个数字,把他的数根求出来,所谓数根,就是把给出的数字各个位数相加,如果不是个位数再相加,直到最后结果是一个个位数为止。然后要求输出这个个位数。
题目有一个小坑,虽然没有给出明确的数字范围,但是在测试数据里面有大数,需要用字符串来解决


题目不是很难,如果知道了数根的计算公式之后更是一个完完全全的水题,一个数num的数根n=num%9,这样就可以轻易的解决。

贴代码
#include<iostream>
using namespace std;
void bignum(string n)
{
	int sum=0;
	int sum1=0;
	for(int i=0;i<n.length();i++)
	{
		sum+=n[i]-'0';
	}
	while(sum)
	{
		sum1+=sum%10;
		sum=sum/10;
	}
	while(sum1>=10)
	{
		sum1=sum1%10+sum1/10;
	}
	//sum1=sum%9?sum%9:9;//这一段使用了公式,如果使用公式之后上面那两个while循环就可以省略了
	cout<<sum1<<endl;
} 
int main()
{
	string n;
	cin>>n;
	while(n!="0")
	{
		bignum(n);
		cin>>n;
	}
	return 0;
}



 
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值