Description
a180285幸运地被选做了地球到喵星球的留学生。他发现喵星人在上课前的点名现象非
常有趣。
假设课堂上有N个喵星人,每个喵星人的名字由姓和名构成。喵星球上的老师会选择
M个串来点名,每次读出一个串的时候,如果这个串是一个喵星人的姓或名的子串,那么
这个喵星人就必须答到。
然而,由于喵星人的字码过于古怪,以至于不能用ASCII码来表示。为了方便描述,
a180285决定用数串来表示喵星人的名字。
现在你能帮助a180285统计每次点名的时候有多少喵星人答到,以及M次点名结束后
每个喵星人答到多少次吗?
Input
现在定义喵星球上的字符串给定方法:
先给出一个正整数L,表示字符串的长度,接下来L个整数表示字符串的每个字符。
输入的第一行是两个整数N和M。
接下来有N行,每行包含第i 个喵星人的姓和名两个串。姓和名都是标准的喵星球上的
字符串。
接下来有M行,每行包含一个喵星球上的字符串,表示老师点名的串。
Output
对于每个老师点名的串输出有多少个喵星人应该答到。
然后在最后一行输出每个喵星人被点到多少次。
Sample Input
2 3
6 8 25 0 24 14 8 6 18 0 10 20 24 0
7 14 17 8 7 0 17 0 5 8 25 0 24 0
4 8 25 0 24
4 7 0 17 0
4 17 0 8 25
6 8 25 0 24 14 8 6 18 0 10 20 24 0
7 14 17 8 7 0 17 0 5 8 25 0 24 0
4 8 25 0 24
4 7 0 17 0
4 17 0 8 25
Sample Output
2
1
0
1 2
【提示】
事实上样例给出的数据如果翻译成地球上的语言可以这样来看
2 3
izayoi sakuya
orihara izaya
izay
hara
raiz
HINT
【数据范围】
对于30%的数据,保证:
1<=N,M<=1000,喵星人的名字总长不超过4000,点名串的总长不超过2000。
对于100%的数据,保证:
1<=N<=20000,1<=M<=50000,喵星人的名字总长和点名串的总长分别不超过100000,保证喵星人的字符串中作为字符存在的数不超过10000。
题解:
因为字符集比较大,我们可以把AC自动机上的每个点搞成map.
每次沿着fail指针暴力往上走即可。
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<map>
#define N 100010
using namespace std;
int L,n,m,x,y,ans1[N],ans2[N],f[N],vis[N];
vector<int>a[N],pos[N],A,B;
map<int,int>ch[N];
struct use{
int cnt,fail[N],q[N];
use(){
cnt=1;
for (int i=-1;i<=10000;i++) ch[0][i]=1;
}
void insert(int x){
scanf("%d",&L);int now=1;int t;
for (int i=1;i<=L;i++){
scanf("%d",&t);
if (!ch[now][t]) ch[now][t]=++cnt;
now=ch[now][t];
}
pos[now].push_back(x);
}
void build(){
int h(0),t(1);
fail[1]=0;q[0]=1;
while (h!=t){
int x=q[h++];
for (map<int,int>::iterator i=ch[x].begin();i!=ch[x].end();i++){
int tt=i->first,k=fail[x];
while (!ch[k][tt]) k=fail[k];
fail[i->second]=ch[k][tt];
q[t++]=i->second;
}
}
}
void update(int x,int k){
for (int i=k;i;i=fail[i]){
if (!vis[i]){
vis[i]=1;A.push_back(i);
for (int j=0;j<pos[i].size();j++)
if(!f[pos[i][j]]){
f[pos[i][j]]=1;B.push_back(pos[i][j]);
ans1[pos[i][j]]++;
ans2[x]++;
}
}
}
}
void calc(int x){
int k(1);
for (int i=0;i<a[x].size();i++){
int t=a[x][i];
while (!ch[k][t]) k=fail[k];
k=ch[k][t];update(x,k);
}
for(int i=0;i<A.size();i++)vis[A[i]]=0;
for(int i=0;i<B.size();i++)f[B[i]]=0;
A.clear();B.clear();
}
}acm;
int main(){
scanf("%d%d",&n,&m);
for (int i=1;i<=n;i++){
scanf("%d",&L);
for (int j=1;j<=L;j++) scanf("%d",&x),a[i].push_back(x);
a[i].push_back(-1);
scanf("%d",&L);
for (int j=1;j<=L;j++) scanf("%d",&x),a[i].push_back(x);
}
for (int i=1;i<=m;i++) acm.insert(i);
acm.build();
for (int i=1;i<=n;i++) acm.calc(i);
for (int i=1;i<=m;i++) printf("%d\n",ans1[i]);
for (int i=1;i<=n;i++){
printf("%d",ans2[i]);
if (i!=n) printf(" ");
}
}