Python-pip 安装失败问题解决

一、问题描述

root@ubuntu:/home/chao# apt-get install python-pip
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 python-pip : 依赖: python-setuptools (>= 0.6c1) 但是它将不会被安装
              推荐: python-dev-all (>= 2.6) 但无法安装它
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

二、解决办法

步骤一

安装aptitude工具
sudo apt-get install aptitude

步骤二

root@ubuntu:/home/chao# aptitude install python-pip

下列“新”软件包将被安装。         
  python-colorama{a} python-distlib{a} python-html5lib{a} python-pip 
  python-setuptools{ab} 
0 个软件包被升级,新安装 5 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 542 kB 的存档。 解包后将要使用 2,513 kB。
下列软件包存在未满足的依赖关系:
 python-setuptools : 依赖: python-pkg-resources (= 3.3-1ubuntu1) 但是 3.3-1ubuntu2 已安装。
下列动作将解决这些依赖关系:

     保持 下列软件包于其当前版本: 
1)     python-pip [未安装的]     
2)     python-setuptools [未安装的]

是否接受该解决方案?[Y/n/q/?] n

下列动作将解决这些依赖关系:

     降级 下列软件包:                                                   
1)     python-pkg-resources [3.3-1ubuntu2 (now) -> 3.3-1ubuntu1 (trusty)]

是否接受该解决方案?[Y/n/q/?] Y

下列软件包将被“降级”:
  python-pkg-resources 
下列“新”软件包将被安装。
  python-colorama{a} python-distlib{a} python-html5lib{a} python-pip 
  python-setuptools{a} 
0 个软件包被升级,新安装 5 个, 1 个被降级, 0 个将被删除, 同时 0 个将不升级。
需要获取 604 kB 的存档。 解包后将要使用 2,513 kB。

您要继续吗?[Y/n/?] Y

读取: 1 http://cn.archive.ubuntu.com/ubuntu/ trusty/universe python-colorama all 0.2.5-0.1ubuntu1 [18.3 kB]
读取: 2 http://cn.archive.ubuntu.com/ubuntu/ trusty/universe python-distlib all 0.1.8-1 [113 kB]
读取: 3 http://cn.archive.ubuntu.com/ubuntu/ trusty/main python-html5lib all 0.999-2 [83.2 kB]
读取: 4 http://cn.archive.ubuntu.com/ubuntu/ trusty/main python-pkg-resources all 3.3-1ubuntu1 [61.9 kB]
读取: 5 http://cn.archive.ubuntu.com/ubuntu/ trusty/main python-setuptools all 3.3-1ubuntu1 [230 kB]
读取: 6 http://cn.archive.ubuntu.com/ubuntu/ trusty/universe python-pip all 1.5.4-1 [97.7 kB]
已下载 604 kB,耗时 1秒 (353 kB/s)   
正在选中未选择的软件包 python-colorama。
(正在读取数据库 ... 系统当前共安装有 236806 个文件和目录。)
正准备解包 .../python-colorama_0.2.5-0.1ubuntu1_all.deb  ...
正在解包 python-colorama (0.2.5-0.1ubuntu1) ...
正在选中未选择的软件包 python-distlib。
正准备解包 .../python-distlib_0.1.8-1_all.deb  ...
正在解包 python-distlib (0.1.8-1) ...
正在选中未选择的软件包 python-html5lib。
正准备解包 .../python-html5lib_0.999-2_all.deb  ...
正在解包 python-html5lib (0.999-2) ...
dpkg:警告:即将把 python-pkg-resources 从 3.3-1ubuntu2 降级到 3.3-1ubuntu1
正准备解包 .../python-pkg-resources_3.3-1ubuntu1_all.deb  ...
正在将 python-pkg-resources (3.3-1ubuntu1) 解包到 (3.3-1ubuntu2) 上 ...
正在选中未选择的软件包 python-setuptools。
正准备解包 .../python-setuptools_3.3-1ubuntu1_all.deb  ...
正在解包 python-setuptools (3.3-1ubuntu1) ...
正在选中未选择的软件包 python-pip。
正准备解包 .../python-pip_1.5.4-1_all.deb  ...
正在解包 python-pip (1.5.4-1) ...
正在处理用于 man-db (2.6.7.1-1ubuntu1) 的触发器 ...
正在设置 python-colorama (0.2.5-0.1ubuntu1) ...
正在设置 python-distlib (0.1.8-1) ...
正在设置 python-html5lib (0.999-2) ...
正在设置 python-pkg-resources (3.3-1ubuntu1) ...
正在设置 python-setuptools (3.3-1ubuntu1) ...
正在设置 python-pip (1.5.4-1) ...

参考文档:http://bbs.csdn.net/topics/390462321

阅读更多
版权声明:本文为博主原创文章,转载请注明出处,谢谢 https://blog.csdn.net/supercooly/article/details/50976358
个人分类: Python
上一篇华为WS326虚拟服务器设置
下一篇Python简单网页爬虫——极客学院视频自动下载
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭