Keywords Search
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 40607 Accepted Submission(s): 12928
Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
Output
Print how many keywords are contained in the description.
Sample Input
1 5 she he say shr her yasherhs
Sample Output
3
Author
Wiskey
Recommend
题意:给定n个模式串,和一个母串,求模式串在母串之中出现的次数。
解法:直接套AC自动机模板即可。
//
// main.cpp
// hdu2222_AC
//
// Created by 蘇與軒 on 15/4/24.
// Copyright (c) 2015年 蘇與軒. All rights reserved.
//
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdlib>
#include <string>
#include <map>
#include <set>
#include <algorithm>
#include <functional>
#define rep(i,a,b) for (int i=a;i<((b)+1);i++)
#define Rep(i,a,b) for (int i=a;i>=b;i--)
#define foreach(e,x) for (__typeof(x.begin()) e=x.begin();e!=x.end();e++)
#define mid ((l+r)>>1)
#define lson (k<<1)
#define rson (k<<1|1)
#define MEM(a,x) memset(a,x,sizeof a)
using namespace std;
const int N=500050;
typedef pair<int, int> pii;
typedef long long ll;
struct Trie{
int next[N][30],fail[N],end[N],root,L;
int id(char ch) {
return ch-'a';
}
int newnode() {
rep(i,0,25) next[L][i]=-1;
end[++L]=0;
return L-1;
}
void init() {
L=0;
root=newnode();
}
void insert(char buf[]) {
int l=(int)strlen(buf)-1,u=root;
rep(i,0,l) {
int x=id(buf[i]);
if (next[u][x]==-1) next[u][x]=newnode();
u=next[u][x];
}
end[u]++;
}
void build() {
queue<int> q;
fail[root]=root;
rep(i,0,25) if (next[root][i]==-1) next[root][i]=root;
else {
fail[next[root][i]]=root;
q.push(next[root][i]);
}
while (!q.empty()) {
int u=q.front();q.pop();
rep(i,0,25) if (next[u][i]==-1) next[u][i]=next[fail[u]][i];
else {
fail[next[u][i]]=next[fail[u]][i];
q.push(next[u][i]);
}
}
}
int query(char buf[]) {
int res=0,l=(int)strlen(buf)-1,u=root;
rep(i,0,l) {
u=next[u][id(buf[i])];
int tmp=u;
while (tmp!=root) {
res+=end[tmp];
end[tmp]=0;
tmp=fail[tmp];
}
}
return res;
}
}AC;
char buf[N<<1];
int main(int argc, const char * argv[]) {
int T;
scanf("%d",&T);
while (T--) {
AC.init();
int n;
scanf("%d",&n);
rep(i,1,n) {
scanf("%s",buf);
AC.insert(buf);
}
AC.build();
scanf("%s",buf);
printf("%d\n",AC.query(buf));
}
return 0;
}