HDU233 还是畅通工程(最小生成树)

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最小的公路总长度。
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
Sample Output
3
5
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;

struct node
{
	int from, to, distance;

};
node hu[10005];
int already[10005];


bool cmp(node x, node y)
{
	return x.distance < y.distance;
}

int _find(int x)
{
	if (already[x] == x)
	{
		return x;
	}
	else
	{
		return already[x] = _find(already[x]);
	}
}


bool merge(int x, int y)
{
	int xx = _find(x);
	int yy = _find(y);
	if (xx == yy)
	{
		return false;
	}
	already[xx] = yy;
	return true;
}

int main()
{
	int n;
	while (~scanf("%d", &n))
	{
		if (n == 0)
		{
			break;
		}
		const int N = n*(n - 1) / 2;
		for (int i = 0; i < N; i++)
		{
			scanf("%d %d %d", &hu[i].from, &hu[i].to, &hu[i].distance);
		}
		sort(hu,hu+N,cmp);

		for (int i = 1; i <= n; i++)
		{
			already[i] = i;
		}
		int sum = 0, count = 0;
		for (int i = 0; i <N; i++)
		{
			
			if (merge(hu[i].from, hu[i].to))
			{
				count++;
				sum += hu[i].distance;
			}
			if(count==n-1)
			{
				break;
			}
			
		}
		printf("%d\n", sum);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值