hdu 5933 ArcSoft's Office Rearrangement

ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are  N  working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into  K  new blocks by the following two operations:

- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the  minimum operations to re-arrange current blocks into  K  block with equal size, please help him.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case begins with one line which two integers  N  and  K , which is the number of old blocks and new blocks.

The second line contains  N  numbers  a1 a2 aN , indicating the size of current blocks.

Limits
1T100
1N105
1K105
1ai105
 

Output
For every test case, you should output  'Case #x: y', where  x indicates the case number and counts from  1 and  y is the minimum operations.

If the CEO can't re-arrange  K  new blocks with equal size,  y equals  -1.
 

Sample Input
  
  
3 1 3 14 3 1 2 3 4 3 6 1 2 3
Sample Output
  
  
Case #1: -1 Case #2: 2 Case #3: 3
 

Source


模拟。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;

int main()
{
	int T;
	ll sum,n,k,a[100010];
	scanf("%lld",&T);
	for(int Count=1;Count<=T;Count++){
		sum=0;
		scanf("%lld%lld",&n,&k);
		for(int i=0;i<n;i++){
			scanf("%lld",&a[i]);
			sum+=a[i];
		}
		if(sum%k){
			printf("Case #%d: -1\n",Count);
			continue;
		}
		ll quantity=sum/k;
		ll temp=0,t;
		ll ans=0;
		for(int i=0;i<n;i++){
			if(temp==0){
				if(a[i]<quantity)
					temp=a[i];
				else{
					t=a[i]/quantity;
					
					if(a[i]%quantity)//刚好能除开和不能除开是两种情况...... 
						ans+=t;
					else
						ans+=t-1;
					
					temp=a[i]%quantity;
				}
			}
			else{
				if(temp+a[i]<quantity){
					temp=temp+a[i];
					ans++;
				}
				else{
					t=(a[i]+temp)/quantity;
					
					if((a[i]+temp)%quantity)
						ans+=t+1;
					else
						ans+=t;
					
					temp=(a[i]+temp)%quantity;
				}
			}
		}
		printf("Case #%d: %lld\n",Count,ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值