HDU 5933 ArcSoft's Office Rearrangement (思维)

ArcSoft’s Office Rearrangement
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4028 Accepted Submission(s): 1260

Problem Description
ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are N working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into K new blocks by the following two operations:

  • merge two neighbor blocks into a new block, and the new block’s size is the sum of two old blocks’.
  • split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the minimum operations to re-arrange current blocks into K block with equal size, please help him.

Input
First line contains an integer T, which indicates the number of test cases.

Every test case begins with one line which two integers N and K, which is the number of old blocks and new blocks.

The second line contains N numbers a1, a2, ⋯, aN, indicating the size of current blocks.

Limits
1≤T≤100
1≤N≤105
1≤K≤105
1≤ai≤105

Output
For every test case, you should output ‘Case #x: y’, where x indicates the case number and counts from 1 and y is the minimum operations.

If the CEO can’t re-arrange K new blocks with equal size, y equals -1.

Sample Input
3
1 3
14
3 1
2 3 4
3 6
1 2 3

Sample Output
Case #1: -1
Case #2: 2
Case #3: 3

题意

给你n个数,将其分成k个相同的数的操作需要多少步,操作有两种,第一种可以将相连的两个数字合并成一个数,这个数等于这两个数的和,或将一个数分解成两个数,这两个数的和等于原来的数

思路

实际上要变为k个相同的数,每次的合并和分解都是必要的,那么可以直接一个数一个数的操作,考虑当前的数,当前的数如果大于平均值那么我们就需要把这个数分解记这个数为a,平均数为b,那么要分解的次数就是a/b,还会剩下a%b个数,可以加到后一个数上去,a%b==0会少余数合并的步骤,如果当前的数小于平均数的话直接加到后一个数上即可,从头到尾跑一遍就可以了

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+10;
long long a[maxn];
typedef long long ll;
int main()
{
    long long n, k;
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld",&n,&k);
        long long sum = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%lld",&a[i]);
            sum += a[i];
        }
        if (sum%k != 0)
        {
            printf("Case #%d: -1\n", cas++);
            continue;
        }
        long long ave = sum / k;
        long long ans = 0;
        for (long long i = 0; i < n; i++)
        {
            if (a[i] == ave)continue;
            if (a[i] >= ave)
            {
                ll x = a[i] / ave;
                if (a[i] %ave != 0)
                {
                    a[i+1] += a[i]%ave;
                    ans += x+1;
                }
                else
                {
                    ans += x-1;
                }
                continue;
            }
            else
            {
                a[i+1]+=a[i];
                ans++;
            }
        }
        printf("Case #%d: %lld\n", cas++, ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值