smb:unrecognized service

[root@sycflash ~]#service smb status

smb:unrecognized service

提示:smb:unrecognized service.这时你会按照常规的方法来查看samba是否已经安装了。于是rpm -qa|grep samba返回如下结果:

[root@sycflash ~]# rpm -qa|grep samba
samba-client-3.0.33-3.28-1.el5
samba-common-3.0.33-3.28-1.el5

这里顺便说一下搭建samba服务器所需要的基本软件包:

1. samba——>这个软件包包含了主要的daemon文件(smbd和nmbd)

2. samba-common——>提供samba的主要配置文件(smb.conf)、smb.conf语法检测程序(testparm)等

3. samba-client——> 当linux作为samba 客户端的时候,提供了一套所需的工具和指令。

这下看出来了吧,samba主程序根本没有被安装,那么现在我们到iso镜像里找到samba的rpm包。

先把iso镜像挂载上,一般情况下光驱的设备标识为/dev/hdc

[root@sycflash ~]# mkdir /mnt/temp

[root@sycflash ~]#mount /dev/hdc /mnt/temp

[root@sycflash ~]#ll /mnt/temp/Server | grep samba

samba-3.0.33-3.28-1.el5.i386.rpm
samba-common-3.0.33-3.28-1.el5.i386.rpm

samba-client-3.0.33-3.28-1.el5.i386.rpm

...

[root@sycflash ~]#rpm -ivh /mnt/temp/Server/samba-3.0.33-3.28-1.el5.i386.rpm

error: Failed dependencies:
perl(Convert::ASN1) is needed by samba-3.0.33-3.28-1.el5.i386

又报错了,原来是缺少所依赖的perl ASN1包。

解决方法:安装perl-Convert-ASN1-0.20-1.1.noarch.rpm

[root@sycflash ~]#rpm -ivh /mnt/temp/Server/perl-Convert-ASN1-0.20-1.1.noarch.rpm

安装成功后,再 [root@sycflash ~]#rpm -ivh /mnt/temp/Server/samba-3.0.33-3.28-1.el5.i386.rpm

这时samba就能正常安装了。check一下成果:

[root@sycflash ~]#service smb status

smbd is stopped

nmbd is stopped

这时已经没有smb:unrecognized service 这样的提示了。

PS:这里的系统为rhel-server-5.5-i386,软件的具体版本可能和您的不一样。

没有更多推荐了,返回首页