HDOJ 1017 基础题

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46372    Accepted Submission(s): 14906


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
   
   
1 10 1 20 3 30 4 0 0
 

Sample Output
   
   
Case 1: 2 Case 2: 4 Case 3: 5


数学好奇心

时间限制:2000/1000 MS(Java / Others)内存限制:65536/32768 K(Java / Others)
总共提交:46372已接受提交:14906


问题描述
给定两个整数n和m,计算整数对(a,b)的个数,使得0 <a <b <n和(a ^ 2 + b ^ 2 + m)/(ab)是一个整数。

这个问题包含多个测试用例!

多输入的第一行是一个整数N,然后是一个空行,后跟N个输入块。每个输入块都采用问题描述中指定的格式。输入块之间有空行。

输出格式由N个输出块组成。输出块之间有空行。
 

输入
您将在输入中获得一些案例。每个案例由包含整数n和m的行指定。输入的结束由n = m = 0的情况表示。您可以假设0 <n <= 100。
 

产量
对于每种情况,请打印案例编号以及满足给定属性的对(a,b)的数量。按照下面的格式在一行上打印每个案例的输出。

思路:
此题关键在如何判断 X除以Y是否为整数。X%Y==0,则相除结果为整数

代码:
#include<stdio.h>
int count(int n,int m)
{
	int i,j,sum=0;
	for(i=1;i<n;i++)  // 0<n<=100,所以i=1
	{
		for(j=i+1;j<n;j++)
		{
			if(((i*i+j*j+m)%(i*j))==0)
				sum++;
		}
	}
	return sum;
}
int main()
{
	int m,n,s,c;
	scanf("%d",&s);
	while(s--)
	{
		c=0;
		while(scanf("%d %d",&n,&m)!=EOF)
		{
			s=count(n,m);
			c++;
			if(n==0&&m==0)
				break;
			printf("Case %d: %d\n",c,s);
		}
		if(s!=0)
			printf("\n");
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值