10382 - Watering Grass
Time limit: 3.000 seconds
n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.
What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?
Input
Input consists of a number of cases. The first line for each case contains integer numbers n, l and w with n <= 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)
Output
For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.
Sample input
8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
16 2
19 4
3 10 1
3 5
9 3
6 1
3 10 1
5 3
1 1
9 1
Sample Output
6
2
-1
贪心里面的区间覆盖问题。
/*0.022s*/
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int MAXN = 10010;
double l, w;
pair<double, double>a[MAXN];
int main(void)
{
int n;
while (~scanf("%d%lf%lf", &n, &l, &w))
{
int m = 0, i, j;
for (i = 0; i < n; i++)
{
double x, r;
scanf("%lf%lf", &x, &r);
if (w > 2 * r)///范围太小
continue;
double tmp = sqrt(r * r - w * w / 4);
a[m++] = make_pair(x - tmp, x + tmp);///记录左右交点
}
sort(a, a + m);///pair数组和sort的灵活运用
double low = 0.0, up = 0.0;
int cnt = 0;
bool flag = false;
for (i = 0; i < m; i++)
{
if (a[i].first > up)
break;
if (a[i].second > up)
{
for (j = i; j < m && a[j].first <= low; j++)
if (a[j].second > up)
up = a[j].second;
cnt++;
if (up >= l)
{
flag = true;
break;
}
low = up;
}
}
printf("%d\n", flag ? cnt : -1);
}
return 0;
}