UVA 10382 Watering Grass (贪心 + 区间覆盖问题)

Problem E
Watering Grass
Input:
 standard input
Output: standard output
Time Limit: 3 seconds

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?

Input

Input consists of a number of cases. The first line for each case contains integer numbers nl and w with n <= 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

 

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.

Sample input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

 

Sample Output

6

2

-1



题意:给定一条草坪。草坪上有n个喷水装置。草坪长l米宽w米。。n个装置都有每个装置的位置和喷水半径。。要求出最少需要几个喷水装置才能喷满草坪。。喷水装置都是装在草坪中间一条水平线上的。。

思路;区间覆盖问题。用贪心。按覆盖最远的排序。。每次找最远的然后更行左边界。。

不过这题有个要注意的地方是圆的话。最远覆盖点要去进行计算。为和草坪上下边交点为最远。根据勾股定理很容易算出

代码:

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;

int n;
double l, w;
double v, r;
int num;
struct O {
    double l, r;
} yuan[10005];

int cmp(O a, O b) {
    return a.r > b.r;
}
int main() {
    while (~scanf("%d%lf%lf", &n, &l, &w)) {
	double go = 0;
	num = 0;
	for (int i = 0; i < n; i ++) {
	    scanf("%lf%lf", &v, &r);
	    yuan[i].l = v - sqrt(r * r - w * w / 4);//计算右覆盖最远距离
	    yuan[i].r = v + sqrt(r * r - w * w / 4);//计算左覆盖最远距离
	}
	sort(yuan, yuan + n, cmp);
	while (go < l) {
	    int i;
	    for (i = 0; i < n; i ++) {
		if (yuan[i].l <= go && yuan[i].r > go) {
		    go = yuan[i].r;//更新区间左端。
		    num ++;
		    break;
		}
	    }
	    if (i == n)
		break;
	}
	if (go < l) printf("-1\n");
	else printf("%d\n", num);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值