UVaOJ10382 - Watering Grass

10382 - Watering Grass

Time limit: 3.000 seconds

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?

Input

Input consists of a number of cases. The first line for each case contains integer numbers nl and w with n <= 10000. The next nlines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

 

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.

Sample input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

 

Sample Output

6

2

-1


(Regionals 2002 Warm-up Contest, Problem setter: Piotr Rudnicku)

 

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;

const int MAXN = 10005;
int n, nIndex;
double l, w;
struct Node {
    double left, right;
    friend bool operator < (const Node &a, const Node &b) {
        return a.left < b.left;
    }
}arr[MAXN];
int main() {
    double p, r;
    while (scanf("%d%lf%lf", &n, &l, &w) != EOF) {
        nIndex = 0;
        for (int i = 0; i < n; i ++) {
            scanf("%lf%lf", &p, &r);
            if (r < w / 2) continue;
            double t = sqrt(r * r - w * w / 4.0);
            arr[nIndex].left = p - t;
            arr[nIndex].right = p + t;
            nIndex ++;
        }
        sort(arr, arr + nIndex);
        int cnt = 0;
        double left = 0, right = 0;
        bool flag = false;
        if (arr[0].left <= 0) {
            int i = 0;
            while (i < nIndex) {
                int j = i;
                while (j < nIndex && left >= arr[j].left) {
                    if (arr[j].right > right) {
                        right = arr[j].right;
                    }
                    j ++;
                }
                if (j == i) break;
                cnt ++;
                i = j;
                left = right;
                if (left >= l) {
                    flag = true;
                    break;
                }
            }
        }
        if (flag) {
            printf("%d\n", cnt);
        } else {
            printf("-1\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值