UVa 10929 You can say 11 (数论)

262 篇文章 0 订阅
100 篇文章 0 订阅

10929 - You can say 11

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1870

Introduction to the problem

Your job is, given a positive number N, determine if it is a multiple of eleven.

Description of the input

The input is a file such that each line contains a positive number. A line containing the number 0 is the end of the input. The given numbers can contain up to 1000 digits.

Description of the output

The output of the program shall indicate, for each input number, if it is a multiple of eleven or not.

Sample input:

112233
30800
2937
323455693
5038297
112234
0

Sample output

112233 is a multiple of 11.
30800 is a multiple of 11.
2937 is a multiple of 11.
323455693 is a multiple of 11.
5038297 is a multiple of 11.
112234 is not a multiple of 11.


方法1:直接从个位数开始mod 11计算。

/*0.026s*/

#include<cstdio>
#include<cstring>

char s[1005];

int main(void)
{
	int remainder;
	while (gets(s), strcmp(s, "0"))
	{
		remainder = 0;
		for (int i = 0; s[i]; i++)
			remainder = (remainder * 10 + (s[i] & 15)) % 11;
		if (remainder) printf("%s is not a multiple of 11.\n", s);
		else printf("%s is a multiple of 11.\n", s);
	}
	return 0;
}

方法2:若一个整数的奇位数字之和与偶位数字之和的差能被11整除,则这个数能被11整除。

证明:比如num = 10000a4+1000a3+100a2+10a1+a0=(a4+a2+a0-a3-a1)+(9999a4+99a2+1001a3+11a1)

因为11 | 99,所以11 | (9900+99)

因为11 | 1111,所以11 | (1111-110)

所以...

/*0.025s*/

#include<cstdio>
#include<cstring>

char s[1005];

int main(void)
{
	int l, i, sum;
	while (gets(s), strcmp(s, "0"))
	{
		l = strlen(s), sum = 0;
		for (i = 0; i < l; i += 2) sum += s[i] & 15;
		for (i = 1; i < l; i += 2) sum -= s[i] & 15;
		if (sum % 11) printf("%s is not a multiple of 11.\n", s);
		else printf("%s is a multiple of 11.\n", s);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值