UVa 757 / POJ 1042 / East Central North America 1999 Gone Fishing (枚举&贪心&想法题&优先队列)

119 篇文章 0 订阅

757 - Gone Fishing

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=698

http://poj.org/problem?id=1042

John is going on a fishing trip. He has h hours available ( $1 \leŸ h \leŸ 16$), and there are n lakes in the area ( $2 \leŸ n \leŸ 25$) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each $i = 1, \dots, n- 1$, the number of 5-minute intervals it takes to travel from lakei to lake i + 1 is denoted ti ( $0 < t_i \leŸ 192$). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4.


To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi ( $f_i \ge– 0$), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di ( $d_i \ge– 0$). If the number of fish expected to be caught in an interval is less than or equal to di, there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.


Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input 

You will be given a number of cases in the input. Each case starts with a line containing  n . This is followed by a line containing  h . Next, there is a line of  n  integers specifying  f i  (  $1 \leŸ i \leŸ n$ ), then a line of  n  integers  d i  (  $1 \leŸ i \leŸ n$ ), and finally, a line of  n  - 1 integers  t i  (  $1 \leŸ i Ÿ\le n - 1$ ). Input is terminated by a case in which  n  = 0.

Output 

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input 

2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0

Sample Output 

45, 5
Number of fish expected: 31

240, 0, 0, 0
Number of fish expected: 480

115, 10, 50, 35
Number of fish expected: 724

首先枚举去哪些湖钓鱼。

由于每个湖中鱼的数量只与钓了多长时间有关,与什么时候钓无关。因此我们可以一次将移动的时间全部扣除,这样每时每刻我们都可以选择鱼数量最多的湖。


完整代码:

/*UVa: 0.059s*/
/*POJ: 110ms,176KB*/

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

int d[30], f[30], cost[30], h, n, ans[30], maxi;

struct lake
{
	int fi;
	int id;
	bool operator < (const lake p) const
	{
		if (fi == p.fi)
			return id > p.id;
		return fi < p.fi;
	}
} la[30], tt;

void solve()
{
	priority_queue<lake>Q;
	int i, j, t, gf, tp[30];
	maxi = -1;
	for (i = 1; i <= n; i++)
	{
		while (!Q.empty()) Q.pop();
		memset(tp, 0, sizeof(tp));
		gf = 0;
		t = h * 12 - cost[i];
		for (j = 1; j <= i; j++)
		{
			la[j].fi = f[j], la[j].id = j;
			Q.push(la[j]);
		}
		for (j = 0; j < t; j++)
		{
			tt = Q.top();
			Q.pop();
			gf += tt.fi;
			tp[tt.id]++;
			if (tt.fi - d[tt.id] > 0)
				tt.fi -= d[tt.id];
			else
				tt.fi = 0;
			Q.push(tt);
		}
		if (gf > maxi)
		{
			maxi = gf;
			for (j = 1; j <= n; j++)
				ans[j] = tp[j] * 5;
		}
	}
}

int main(void)
{
	bool flag = 0;
	int i;
	cost[1] = 0;
	while (scanf("%d", &n), n)
	{
		memset(ans, 0, sizeof(ans));
		if (flag) putchar('\n');
		flag = 1;
		scanf("%d", &h);
		for (i = 1; i <= n; i++)
			scanf("%d", &f[i]);
		for (i = 1; i <= n; i++)
			scanf("%d", &d[i]);
		for (i = 2; i <= n; i++)
			scanf("%d", &cost[i]);
		for (i = 3; i <= n; i++)
			cost[i] = cost[i] + cost[i - 1];
		solve();
		printf("%d", ans[1]);
		for (i = 2; i <= n; i++)
			printf(", %d", ans[i]);
		printf("\n");
		printf("Number of fish expected: %d\n", maxi);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值