UVa 10252 Common Permutation (water ver.)

10252 - Common Permutation

Time limit: 3.000 seconds 

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1193

Given two strings of lowercase letters, a and b, print the longest string x of lowercase letters such that there is a permutation of x that is a subsequence of a and there is a permutation of x that is a subsequence of b.

 

Input

Input file contains several lines of input. Consecutive two lines make a set of input. That means in the input file line 1 and 2 is a set of input, line 3 and 4 is a set of input and so on. The first line of a pair contains a and the second contains b. Each string is on a separate line and consists of at most 1000 lowercase letters.

 

Output

For each set of input, output a line containing x. If several x satisfy the criteria above, choose the first one in alphabetical order.

 

Sample Input:

pretty
women
walking
down
the
street
 

Sample Output:

e

nw

et


水。


完整代码:

/*0.019s*/

#include<bits/stdc++.h>
using namespace std;

char a[1005], b[1005], ans[1005];
bool vis[1005];

void solve(char* a, char* b)
{
	int lena = strlen(a), lenb = strlen(b), i, j, c = 0;
	memset(vis, 0, sizeof(vis));
	for (i = 0; i < lena; ++i)
		for (j = 0; j < lenb; ++j)
		{
			if (!vis[j] && a[i] == b[j])
			{
				ans[c++] = a[i];
				vis[j] = true;
				break;
			}
		}
	ans[c] = 0;
	sort(ans, ans + c);
	puts(ans);
}

int main()
{
	while (gets(a))
	{
		gets(b);
		if (strlen(a) < strlen(b)) solve(a, b);
		else solve(b, a);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值