HDU 2973 / UVa 1434 / CERC 2008 YAPTCHA (威尔逊定理及其逆定理)

262 篇文章 0 订阅
100 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=2973

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=516&page=show_problem&problem=4180

Problem Description
The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

where [x] denotes the largest integer not greater than x.
 

Input
The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).
 

Output
For each n given in the input output the value of Sn.
 

Sample Input
  
  
13 1 2 3 4 5 6 7 8 9 10 100 1000 10000
 

Sample Output
  
  
0 1 1 2 2 2 2 3 3 4 28 207 1609
 

Source

思路:

n是合数时,((n-1)!+1)/n不为整数,所以在题目的和式中该部分为0;n是质数时就为1了。

所以筛一遍素数,在筛的过程中,找出形如3k+7的素数即可。


额外说一句,当a,b互素时,形如an+b的素数有无穷个。(wiki:Dirichlet's theorem on arithmetic progressions


完整代码:

/*796ms,8060KB*/

#include<cstdio>
#include<cmath>
const int mx = 3 * 1000000 + 7 + 1;
const int sqrt_mx = (int)sqrt((double)mx);
const int mx_n = 1000000 + 1;

bool a[mx_n], vis[mx];
int s[mx_n];

void init()
{
	int i, j;
	for (i = 2; i < mx; ++i)
	{
		if (!vis[i])
		{
			if ((i - 7) % 3 == 0) a[(i - 7) / 3] = true;
			if (i <= sqrt_mx)
				for (j = i * i; j < mx ; j += i) vis[j] = true;
		}
	}
}

int main()
{
	init();
	for (int i = 2; i < mx_n; ++i)
		s[i] = s[i - 1] + a[i];
	int t, n;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &n);
		printf("%d\n", s[n]);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值