数学->hdu 2973

YAPTCHA
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

where [x] denotes the largest integer not greater than x.
 

Input

The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).
 

Output

For each n given in the input output the value of Sn.
 

Sample Input

     
     
13 1 2 3 4 5 6 7 8 9 10 100 1000 10000
 

Sample Output

     
     
0 1 1 2 2 2 2 3 3 4 28 207 1609
 

#include <iostream>
#include <string.h>
#include <cmath>

using namespace std;

#define MAXN 3000000 + 10

bool is_prime[MAXN];
int n;
int s[MAXN];

void prime()
{
    memset(is_prime, false, sizeof(is_prime));

    is_prime[0] = is_prime[1] = true;

    for (int i = 2; i < 1800; i++)
    {
        if (!is_prime[i])
        {
            int temp = i * 2;

            while (temp <= MAXN)
            {
                is_prime[temp] = true;
                temp += i;
            }
        }
    }
}

void init()
{
    s[0] = 0;
    for(int i = 1; i <= 1000000; i++)
    {
        if(!is_prime[i * 3 + 7])
        {
            s[i] = s[i - 1] + 1;
        }
        else
        {
            s[i] = s[i - 1];
        }
    }
}

void input()
{
    int t;

    prime();
    init();

    cin >> t;
    while (t--)
    {
        cin >> n;

        cout << s[n] << endl;
    }
}

int main()
{
    std::ios::sync_with_stdio(false);
    input();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值