HDU 2973 威尔逊定理

http://acm.hdu.edu.cn/showproblem.php?pid=2973

The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute


where [x] denotes the largest integer not greater than x.

Input

The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).

Output

For each n given in the input output the value of Sn.

Sample Input

13
1
2
3
4
5
6
7
8
9
10
100
1000
10000

Sample Output

0
1
1
2
2
2
2
3
3
4
28
207
1609

题目大意:就是求那个式子的结果,[x]表示小于等于x的最大的整数。

思路:威尔逊定理,当且仅当n为素数时,n整除(n-1)!+1,那么我们考虑两种情况:(1)当3k+7为素数时,由定理,我们可设(n-1)!+1=kn,那么式子的左半部分是k,设右半部分的数为x,右半部分的分子只比左半部分的分子少了1,所以右半部分是一个非常接近k的数,那么[x]=k-1,所以最终的答案是[k-(k-1)]=1;(2)当3k+7为合数时,(3k+6)!/(3k+7)必定可以化简成一个整数,(一个合数必定可以表示成几个质数的乘积)我们设其为t,左边部分的分子就比右边部分的分子大1,1必定比分母少,因此左边是一个略微大于t的数,设其为x,则[x]=t,因此最终的答案是[t-t]=0。综上,我们枚举范围内的素数即可得到结果。

#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<map>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
#define EPS 1e-10
typedef long long ll;
typedef unsigned long long ull;
using namespace std;

const int maxn=3000010;
int vis[maxn];
int cnt[maxn];

int main()
{
	memset(cnt,0,sizeof(cnt));
	memset(vis,0,sizeof(vis));
	vis[1]=1;
	for(int i=2;i*i<=maxn;i++)
		if(!vis[i])
			for(int j=i*i;j<=maxn;j+=i)
				vis[j]=1;
	for(int i=10;i<maxn;i+=3)
	{
		if(vis[i])
			cnt[i]=cnt[i-3];
		else
			cnt[i]=cnt[i-3]+1;
	}
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		printf("%d\n",cnt[3*n+7]);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值