POJ 3070 Fibonacci(矩阵快速幂)

119 篇文章 0 订阅
100 篇文章 0 订阅
Fibonacci

Time Limit:  1000MS
Memory Limit: 65536K

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

这题让我见识到了矩阵的巨大威力。。(稍微回忆了下矩阵在18~19世纪的发展)

完整代码:
/*0ms,164KB*/

#include <cstdio>
#include <cstring>
const int f0 = 0;
const int f1 = 1;
const int mod = 10000;

int n;

struct mat
{
	int v[2][2];
	mat()
	{
		memset(v, 0, sizeof(v));
	}
} matrix, tmp;

mat operator *(mat a, mat b)
{
	mat c;
	for (int i = 0; i < 2; i++)
		for (int j = 0; j < 2; j++)
			for (int k = 0; k < 2; k++)
				c.v[i][j] = (c.v[i][j] + a.v[i][k] * b.v[k][j]) % mod;
	return c;
}

mat matrix_qiuck_pow(mat a, int k)
{
	mat b;
	b.v[0][0] = 1;
	b.v[1][1] = 1;
	while (k)
	{
	    ///位运算求快速幂
	    ///由于十进制化二进制的过程是先算出低位的,刚好符合我们计算快速幂的方法!
		if (k & 1)
			b = b * a;
		k >>= 1;
		a = a * a;
	}
	return b;
}

int main()
{
    /*
    我是按
        F(n-1) Fn
        Fn     F(n+1)
    来排的
    */
	tmp.v[0][0] = 0;
	tmp.v[0][1] = 1;
	tmp.v[1][0] = 1;
	tmp.v[1][1] = 1;
	while (scanf("%d", &n), ~n)
	{
		matrix = tmp;
		if (n == 0)
			puts("0");
		else
			printf("%d\n", matrix_qiuck_pow(matrix, n - 1).v[1][1]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值